620 St Kilda Road, Melbourne

Incident Report for DGtek Network

Resolved

A power outage in the area has been resolved, and services are back online.
Posted Mar 22, 2025 - 14:02 AEDT

Investigating

Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Mar 22, 2025 - 08:13 AEDT