620 Collins Street, Melbourne

Incident Report for DGtek Network

Resolved

Faulty switch has been replaced, and services are back online.
Posted Apr 22, 2025 - 12:11 AEST

Identified

A faulty switch has been identified by DGtek Field technicians, and will need to be replaced. Further updates to be provided as they come to us.
Posted Apr 22, 2025 - 10:14 AEST

Update

DGtek network engineers have been unable to contact the building manager to investigate this incident. DGtek field technicians have been scheduled for Tuesday morning.
Posted Apr 21, 2025 - 15:04 AEST

Investigating

Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Apr 21, 2025 - 08:51 AEST