576 StKilda Road, Melbourne, 3004, Victoria

Incident Report for DGtek Network

Resolved

No abnormality detected during monitoring period. System back to normal.
Posted Jul 03, 2025 - 13:15 AEST

Monitoring

The building manager has confirmed that some breakers had tripped. The electrician has resolved the issue. Our technical team is currently monitoring the system closely.
Posted Jul 03, 2025 - 10:41 AEST

Identified

The Building Manager has advised that a power issue is affecting Levels 10 to 19 in the West building. An electrician is expected to attend the site by 10:00 AM AEST to investigate further.

We will provide an update once more information becomes available.
Posted Jul 03, 2025 - 09:25 AEST

Investigating

Engineers have observed network alarms at the listed site which are causing disruption to some customer services. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.
Posted Jul 03, 2025 - 08:01 AEST