Call Center Issue

Incident Report for DGtek Network

Resolved

This incident has been resolved.
Posted Jan 28, 2026 - 11:27 AEDT

Investigating

We are currently experiencing a technical issue impacting our phone lines, and our team is unable to receive incoming calls at this time.

Our vendor has been engaged and is actively working to identify the cause and restore full functionality as quickly as possible.

We will provide further updates as soon as more information becomes available.
Posted Jan 28, 2026 - 09:37 AEDT