28 Clarendon Street, Southbank
Incident Report for DGtek Network
Resolved
This incident has been resolved.
Posted Mar 21, 2023 - 08:01 AEDT
Investigating
Engineers have observed network alarms at 28 Clarendon Street, Southbank. This is causing some services to be offline. Engineers are now investigating the issue. Further updates will be given as soon as they are available.

We apologise for any inconvenience caused and are working to resolve issue as soon as possible.

If you require further information relating to this incident, please e-mail us on support@dgtek.net or call 1800 359 602.
Posted Mar 20, 2023 - 19:56 AEDT